BicBucStriim 1.1, kleinere Neuerungen

Die neue Version von BicBucStriim steht nun schon seit einiger Zeit zur Verfügung, aber ich kam erst jetzt dazu, etwas darüber zu schreiben. Gleich vorweg, es gibt keine revolutionären Neuerungen, sondern eher einige neue, nützlich Eigenschaften.

Die Neuerungen in Version 1.1 sind:

  • Bücher können nun an Kindle-Geräte per E-Mail versendet werden, Code gespendet von @janeczku
  • es gibt nun eine globale Suche, die ihre Ergebnisse nach Kategorien geordnet anzeigt
  • der Downloadschutz kann nun mit Schlagworten flexibler eingestellt werden, Code gespendet von @blowk
  • neben den Standard-Daten von Calibre, werden nun auch selbst definierte Spalten angezeigt
Eigene Spalten, die in Calibre definiert wurden, werden nun auch angezeigt

Eigene Spalten, die in Calibre definiert wurden, werden nun auch angezeigt

Calibre erlaubt ja zusätzlich Spalten anzulegen, in denen eigene Daten untergebracht werden können, im Gegensatz zu den Standardspalten, die ja oft mit Metadaten aus den Buchdateien selbst gefüllt werden. Diese Zusatzspalten können einfache Werte aller Art (Text, Zahlen, Bewertungen) sein, aber auch allerlei Zusammensetzungen, Kombinationen aus verschiedenen Spalten.

BicBucStriim zeigt diese selbst definierten Spalten in einem neuen Abschnitt innerhalb der Detailanzeige eines Titels an. Aus technischen Gründen beschränken wir uns aber auf einfache Werte. Komplexe, zusammengesetzte Felder werden hiervon nicht erfasst.

Heruntergeladen kann die Anwendung wie immer von der Softwareseite.  Die Datei BicBucStriim-1.1.0.zip ist für alle Anwender mit einer PHP-Version 5.3+ gedacht, die Datei BicBucStriim-52-1.1.0.zip für Anwender, die noch auf PHP 5.2 angewiesen sind. Wie sich heraus stellte, war eine der verwendeten Bibliotheken schon länger nicht mehr kompatibel mit PHP 5.2. Somit war diese Sonderversion nötig.

Allerdings wird dies die letzte Version von BicBucStriim für PHP 5.2 sein. Aus anderen technischen Gründen unterstützt die Anwendung ab der nächsten Version nur noch PHP 5.3+.